Release 2.2.1 for iOS 9/17/14


  • Some bug fixes

Requirements: iOS 4.3 or later. Compatible with iPhone, iPad, and iPod touch. This app is optimized for iPhone 5

Have more questions? Submit a request